Перенос документов между идентичными конфигурациями для платформы не ниже 8.2.18.82

Публикация № 195701

Разработка - Обмен данными 1С - Перенос данных из 1C8 в 1C8

Обработка выполняет перенос документов между идентичными конфигурациями на платформе не ниже 8.2.18.82. Тестирование выполнялось для конфигурации "Бухгалтерия предприятия версия 2.0.49.15"

Синхронизация объектов конфигураций выполняется по уникальным идетификаторам.

Скачать файлы

Наименование Файл Версия Размер
Перенос между идентичными конфигурациями
.epf 31,14Kb
09.08.13
874
.epf 5 31,14Kb 874 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо развёрнутое
Свернуть все
1. paulpit 18 30.07.13 00:30 Сейчас в теме
Обработка переносит измененные документы?
А чем не устроила универасльная обработка с ИТС-а?
2. XSlava 142 30.07.13 07:50 Сейчас в теме
Этой обработке все равно изменен или не изменен документ, т.к. в качестве основного правила обмена используется сама структура конфигурации (метаданные). Почему не с ИТС, искать, затем разбираться и проверять, тоже самое по времени, что и написать. Скорее всего для типовой обработки нужны еще и правила.
Надеюсь, что ответил на ваши вопросы.
10. apostal86 227 08.08.13 13:45 Сейчас в теме
(2) XSlava, Стандартную ИТС-кую проверять не нужно, с ней все ОК, работает во всех идентичных конфигурациях. Для типовой правила не нужны. То что у Вас выложено практически то же самое, что и в обработке с ИТС. Какое у Вашей обработки принципиальное отличие?
3. awbyk 77 01.08.13 11:14 Сейчас в теме
Попробовал перенос для БГУ из редакции 1.0.14.2 в редакцию 1.0.20.6

Пришлось слегка подправить модуль формы:
- Организации изменил на Учреждения;
- Обошел попыткой, исключением, поскольку в редакции 1.0.14.2 нет константы.ЗаголовокСистемы строку
ЭтаФорма.Заголовок = ЭтаФорма.Заголовок + " " + константы.ЗаголовокСистемы.Получить();
- Список видов документов отсортировал по представлению.

В принципе удобнее, чем универсальный перенос.
4. Жискар 10 05.08.13 12:39 Сейчас в теме
Запускал в «Зарплата и кадры бюджетного учреждения, редакция 1.0 (1.0.60.3)» ,
«Бухгалтерия предприятия, редакция 2.0 (2.0.49.11)».
Платформа 1С:Предприятие 8.2 (8.2.18.109).
Получал сообщение «Обработка завершена».
Ни одной записи в результат не перенесено.
Может что-то ещё надо установить, чтобы обработка работала?
5. XSlava 142 05.08.13 14:36 Сейчас в теме
На закладке "Настройки переноса" нужно выбрать вид документа, затем нажать кнопку "Заполнить", за указанный период будет заполнена таблица переносимых документов. Затем переносить.
6. Жискар 10 05.08.13 15:16 Сейчас в теме
Брал один вид документа "Начисление зарплаты" по одной организации и за период с февраля по апрель.
Вибиралось штук 5. Нажал выполнить. Обработка завершена.
Перенесено 0 документов. Все гладко, только результата нет.
7. XSlava 142 05.08.13 15:28 Сейчас в теме
Значит при переносе есть ошибки, их можно посмотреть создав файл отладки.
8. Жискар 10 05.08.13 16:13 Сейчас в теме
Файл отладки не создается вообще, даже пустой. Машина домашняя, доступно всё.
15. XSlava 142 09.08.13 13:41 Сейчас в теме
16. Жискар 10 09.08.13 15:32 Сейчас в теме
(15) XSlava, Все прекрасно работает. Спасибо.
Началась новая жизнь.
17. XSlava 142 09.08.13 15:35 Сейчас в теме
(16) Жискар, Хорошо. Пишите, если будут идеи по улучшению.
9. XSlava 142 05.08.13 16:44 Сейчас в теме
Странно. "Начисление зарплаты" говорите. Посмотрю.
11. XSlava 142 08.08.13 14:15 Сейчас в теме
Видимо отличается формой.
12. Жискар 10 08.08.13 15:27 Сейчас в теме
apostal86. Извиняюсь за серость. Стандартная ИТС-кая это ВыгрузкаЗагрузкаДанныхXML82.epf
или что-то другое?
13. XSlava 142 08.08.13 15:43 Сейчас в теме
Я не знаю, никогда не пользовался. Возникла необходимость, написал свою.
14. Slater_7 09.08.13 09:35 Сейчас в теме
Таже ерудна что и у Жискар. Говорит что Завершено, но ничего не переносит и отладка не создаётся. Конфа - Бухгалтерия для Казахстана(2.0.11.8) 1С:Предприятие 8.2 (8.2.18.102). Где копать хотябы - есть идеи?
18. hawl 12.08.13 13:05 Сейчас в теме
Спасибо большое, всё работает хорошо.
19. ilsijar 61 23.09.13 10:38 Сейчас в теме
Не очень универсален, но доработать для себя можно.Спасибо,сэкономила время.
20. silver-747 17.10.13 19:58 Сейчас в теме
Спасибо. выручила обработка.
21. Felix1 10.11.13 21:14 Сейчас в теме
Выдает ошибку "
{ВнешняяОбработка.ПереносМеждуИдентичнымиКонфигурациями.МодульОбъекта(46)}: Ошибка при вызове метода контекста (Записать)
о.Записать();
по причине:
Произошла исключительная ситуация (1C:Enterprise 8.2.16.368): Не удалось записать "Счет на оплату покупателю ДПб00000365 от 23.08.2013 16:23:45"!
"
22. Felix1 10.11.13 21:16 Сейчас в теме
не понимаю в чем проблема ? переношу документы за 4 кв 2013 г, в базе приемнике установил дату запрета редактирования по 30.09.2013 ? вопрос причем тут счет от23.08.2013
23. XSlava 142 11.11.13 08:42 Сейчас в теме
Скорее всего в каком нибудь переносимом документе есть ссылка на данный счет, вот он его и переносит.
24. Felix1 11.11.13 08:57 Сейчас в теме
А что с этим делать ???, если я сниму дату запрета редактирования, то у меня поедет прошлый период ?
25. XSlava 142 11.11.13 10:04 Сейчас в теме
(24) Felix1, Один из вариантов очистить ссылку на данный документ в переносимом документе. Решение данной проблемы зависит от задач которые вы решаете.
26. Felix1 11.11.13 11:21 Сейчас в теме
хорошо , а как мне найти тот самый документ,
на который ссылается на счет ???
27. XSlava 142 11.11.13 11:40 Сейчас в теме
(26) Felix1, Написать запрос, затем обработку.
28. Felix1 11.11.13 11:46 Сейчас в теме
(27) XSlava, А для бухгалтера, есть вариант по проще ???
32. likan 27.11.13 08:52 Сейчас в теме
(26)а найти счет и посмотреть подчиненные документы, религия не позволяет?
33. Felix1 27.11.13 12:47 Сейчас в теме
(32) likan, 1.Вопрос уже решен стандартной обработкой с ИТС
2. Если есть конкретные предложения, или желаете помочь, пишите по делу, религия тут не причем.
29. XSlava 142 11.11.13 12:01 Сейчас в теме
30. Felix1 11.11.13 12:39 Сейчас в теме
(29) XSlava, Тогда у меня оборотно-сальдовая ведомость не изменится ??? и вообще все показатели ???
31. XSlava 142 11.11.13 12:50 Сейчас в теме
(30) Felix1, Сделайте резервную копию, проверьте сначала на копии. У вас очень серьезные вопросы, для ответа на которые нужно знать гораздо больше о ваших задачах, чем выпи пишете.
34. imarok 30.11.13 15:22 Сейчас в теме
при выполнение обработки в ут 10.3.15.9 ошибка
{Обработка.ПереносМеждуИдентичнымиКонфигурациями.МодульОбъекта(139)}: Ошибка при вызове метода контекста (СоздатьЭлемент)
ОЭлемент = Открытие.Справочники[ВидСпр].СоздатьЭлемент();
по причине:
Произошла исключительная ситуация (1C:Enterprise 8.2.18.109): {Справочник.Номенклатура.МодульОбъекта(122,33)}: Переменная не определена (РаботаСТорговымОборудованием)
35. imarok 30.11.13 15:34 Сейчас в теме
Разобрался, прошу прощения
36. tanselja 4 30.11.13 16:04 Сейчас в теме
Вроде и стандартная хорошо работает.
37. yalo 03.12.13 09:42 Сейчас в теме
А в чем отличие от стандартной обработки? Использую ее, переносит все необходимые документы и справочники и т.д.
38. Natuhai 3 20.01.14 18:39 Сейчас в теме
Спасибо. Пригодилась обработка. Бухи потерли полтора десятка документов с табличной частью этак в 3000 строк ... Перенес им из бекапа.
39. Alister 9 23.01.14 15:33 Сейчас в теме
Спасибо за работу, все что нужно перенесла.
40. if56 19.02.14 14:52 Сейчас в теме
Есть ошибка.
Если не устанавливать флаг Перезаписывать документы, то таб части документов , перенесенных ранее , задваиваются. Ошибка в функции ПолучитьДокумент(ТекДок)

Кусок кода:

Если ФлПерезаписыватьДоки и не ЭтоНовый тогда
инфа("Документ уже переносился!!! Изменяем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);
//Очистим табличные части
Для каждого ТЧ из Открытие.Метаданные.Документы[ВидДока].ТабличныеЧасти цикл
ДокБух[ТЧ.Имя].Очистить();
КонецЦикла;
ИначеЕсли не ФлПерезаписыватьДоки и не ЭтоНовый тогда // Все равно пишем
инфа("Документ уже переносился!!! Пропускаем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);
//////////////////////////////////////// надо бы Возврат Неопределено;

Иначе
инфа("Создаем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);
КонецЕсли;
Возврат ДокБух;
КонецКуска
41. arjuna 26.03.14 00:43 Сейчас в теме
(40) if56.ru,
Есть ошибка.
Если не устанавливать флаг Перезаписывать документы, то таб части документов , перенесенных ранее , задваиваются. Ошибка в функции ПолучитьДокумент(ТекДок)

У меня упорно задваивает все документы. Уже всю голову сломал, не видет он УникальныйИдентификатор в удаленной базе.
42. sps02 14.08.14 15:21 Сейчас в теме
Извините, если вопрос глупый(( Могу ли я перенести документы из одинаковых конфигураций, но если это разные контрагенты?
Спасибо заранее
43. sps02 14.08.14 17:39 Сейчас в теме
Закачала, но выдает такую ошибку. подскажите как решить: Не смог записать элемент справочника Номенклатура Набор для кофе "Бернадот 0000" 110 мл на 6перс.12пред {ВнешняяОбработка.ПереносМеждуИдентичнымиКонфигурациями.МодульОбъекта(405)}: Ошибка при вызове метода контекста (Записать): Произошла исключительная ситуация (1C:Enterprise 8.2.19.90): Ошибка при выполнении обработчика - 'ПередЗаписью'
Заранее спасибо
44. sps02 15.08.14 11:40 Сейчас в теме
Скажите, пожалуйста почему номенклатура не загружается?
45. makas 44 08.10.14 18:15 Сейчас в теме
Обработка в 1С:Предприятие 8.2 (8.2.19.106) "Управление торговлей", редакция 10.3 (10.3.29.1) пишет сообщение "База данных не открыта !!!"

В чем может быть моя ошибка?

46. XSlava 142 09.10.14 08:01 Сейчас в теме
В чем угодно. Нет доступа к каталогу или еще чего.
47. SvetlanaP 27.02.15 12:57 Сейчас в теме
Спасибо за обработку! С ней намного легче работать. Сначала все время появлялось сообщение "База данных не открыта!!!", но потом все получилось. У меня все переносится идеально.
48. Evrey.biysk 11.03.15 06:33 Сейчас в теме
Одна из причин почему база данных не открыта, пробелы в логине или пароле
Если таковые имеются то
v8=Новый COMОбъект("v8"+Прием+".COMConnector");
	Состояние("Подключение к базе");
	строкаЗапуска="";
	Если ФлБазаНаСервере тогда  
		строкаЗапуска = "Srvr="""+ СокрЛП(ф.Сервер) + """;"+"Ref="""+СокрЛП(ф.ИмяБазы)+ """;Usr=" + СокрЛП(ф.ИмяПользователя) + ";Pwd=" + СокрЛП(ф.Пароль);
	иначе	
		строкаЗапуска = "File="""+ СокрЛП(ф.Каталог) + """;Usr=" + СокрЛП(ф.ИмяПользователя) + ";Pwd=" + СокрЛП(ф.Пароль);
		Если не ЗначениеЗаполнено(ф.ИмяПользователя) тогда
			строкаЗапуска = "File="""+ СокрЛП(ф.Каталог) + """";
		КонецЕсли;	
	конецесли;
	
	Сообщить(строкаЗапуска);
	Попытка   		
		Открытие = V8.Connect(строкаЗапуска); 
		Состояние("Подключились"); 
	Исключение 
		Предупреждение("База данных не открыта!!!"); 
		Возврат Ложь; 
	КонецПопытки;
	Возврат Истина;
Показать


Надо заменить следующим:

v8=Новый COMОбъект("v8"+Прием+".COMConnector");
	Состояние("Подключение к базе");
	строкаЗапуска="";
	Если ФлБазаНаСервере тогда  
		строкаЗапуска = "Srvr="""+ СокрЛП(ф.Сервер) + """;"+"Ref="""+СокрЛП(ф.ИмяБазы)+ """;Usr=""" + СокрЛП(ф.ИмяПользователя) + """;Pwd=""" + СокрЛП(ф.Пароль)+"""";
	иначе	
		строкаЗапуска = "File="""+ СокрЛП(ф.Каталог) + """;Usr=""" + СокрЛП(ф.ИмяПользователя) + """;Pwd=""" + СокрЛП(ф.Пароль)+"""";
		Если не ЗначениеЗаполнено(ф.ИмяПользователя) тогда
			строкаЗапуска = "File="""+ СокрЛП(ф.Каталог) + """";
		КонецЕсли;	
	конецесли;
	
	Сообщить(строкаЗапуска);
	Попытка   		
		Открытие = V8.Connect(строкаЗапуска); 
		Состояние("Подключились"); 
	Исключение 
		Предупреждение("База данных не открыта!!!"); 
		Возврат Ложь; 
	КонецПопытки;
	Возврат Истина;
Показать
49. LavinVadik 130 22.10.15 23:35 Сейчас в теме
на 8.3 тоже работает
маленько код надо тока поправить

еще момент если не ставить флажок "перезаписывать документы" и в базе приемники такой документ уже есть,
табличные части дублируются.
вот тут надо добавить что то типа "Если ФлПерезаписыватьДоки тогда"
Функция ПеренстиДокумент(ТекДок)
	ВидДокумента 	= Метаданные.НайтиПоТипу(ТипЗнч(ТекДок));
	ТипДокумента	= ВидДокумента.Имя;
	Синоним			= ВидДокумента.Синоним;
	ОДок = ПолучитьДокумент(ТекДок);
	
	Если ФлПерезаписыватьДоки тогда	
		Для каждого Реквизит из Метаданные.Документы[ТипДокумента].Реквизиты цикл
			Если Открытие.Метаданные.Документы[ТипДокумента].Реквизиты.Найти(Реквизит.Имя) = неопределено тогда
				Продолжить;
			КонецЕсли;	
			ОДок[Реквизит.Имя] = ЗаменитьЗначение(ТекДок[Реквизит.Имя]);
		КонецЦикла;	
		
		
		Для каждого ТабличнаяЧасть из Метаданные.Документы[ТипДокумента].ТабличныеЧасти цикл
			Если Открытие.Метаданные.Документы[ТипДокумента].ТабличныеЧасти.Найти(ТабличнаяЧасть.Имя) = неопределено тогда
				Продолжить;
			КонецЕсли;	
			Для каждого Строка из ТекДок[ТабличнаяЧасть.Имя] цикл
				НоваяСтрока = ОДок[ТабличнаяЧасть.Имя].Добавить();
				Для каждого Реквизит из ТабличнаяЧасть.Реквизиты цикл
					Если Открытие.Метаданные.Документы[ТипДокумента].ТабличныеЧасти[ТабличнаяЧасть.Имя].Реквизиты.Найти(Реквизит.Имя) = неопределено тогда
						Продолжить;
					КонецЕсли;	
					НоваяСтрока[Реквизит.Имя] = ЗаменитьЗначение(Строка[Реквизит.Имя]);
				КонецЦикла;	
			КонецЦикла;
		КонецЦикла;	
	КонецЕсли;	
	
	Если не ВидДокумента.КонтрольУникальности тогда
		ОДок.Номер 	= ТекДок.Номер;
	ИначеЕсли не НайтиДокументПоКоду("Документ", ТипДокумента, ТекДок.Номер, ТекДок.Дата, ВидДокумента.ПериодичностьНомера) тогда
		ОДок.Номер 	= ТекДок.Номер;
	КонецЕсли;	
	
	ОДок.Дата 	= ТекДок.Дата;
	
	ЗаписатьДокумент(ОДок,ТекДок,Синоним);
	Возврат ОДок.Ссылка;
КонецФункции
Показать



//v8=Новый COMОбъект("v8"+Прием+".COMConnector");
v8=Новый COMObject("V83.COMConnector");
или добавить в список выбора "Прием"


и не предусмотрено если в базе приемники такой документ уже есть и он помечен на удаление то документ не проводится, вот пример
надо добавить
Если ДокБух.ПометкаУдаления Тогда
ДокБух.УстановитьПометкуУдаления(Ложь);
КонецЕсли;



Функция ПолучитьДокумент(ТекДок)
	ВидДока = Метаданные.НайтиПоТипу(ТипЗНЧ(ТекДок)).Имя;
	УИ = открытие.NewObject("УникальныйИдентификатор",СокрЛП(""+ТекДок.УникальныйИдентификатор()));
	ЭтоНовый = Ложь;
	ЕстьСсылка = Открытие.Документы[ВидДока].ПолучитьСсылку(УИ);
	Если не ПустаяСтрока(ЕстьСсылка.Номер) тогда
		ДокБух=ЕстьСсылка.ПолучитьОбъект();
		Если ДокБух.ПометкаУдаления Тогда
			ДокБух.УстановитьПометкуУдаления(Ложь);
		КонецЕсли;	

	Иначе
		ДокБух = Открытие.Документы[ВидДока].СоздатьДокумент();
		НоваяСсылка = Открытие.Документы[ВидДока].ПолучитьСсылку(УИ);
		ДокБух.УстановитьСсылкуНового(НоваяСсылка);
		ЭтоНовый = Истина;
	КонецЕсли;
	Если ФлПерезаписыватьДоки и не ЭтоНовый тогда	
		инфа("Документ уже переносился!!! Изменяем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);
		//Очистим табличные части
		Для каждого ТЧ из Открытие.Метаданные.Документы[ВидДока].ТабличныеЧасти цикл
			ДокБух[ТЧ.Имя].Очистить();
		КонецЦикла;	
	ИначеЕсли не ФлПерезаписыватьДоки и не ЭтоНовый тогда	
		инфа("Документ уже переносился!!! Пропускаем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);	
	Иначе	
		инфа("Создаем документ "+ВидДока+" № "+ТекДок.Номер+" от "+ТекДок.Дата,0);
	КонецЕсли;	
	Возврат ДокБух;
КонецФункции
Показать
Светлый ум; +1 Ответить
50. Доня 276 02.03.17 16:06 Сейчас в теме
(49)
Вы в комментариях написали :
<<< 49. Вадик Лавин (LavinVadik) 57 22.10.15 23:35
на 8.3 тоже работает
маленько код надо тока поправить ...>>>
не могли бы Вы скинуть поправленный на мою почту tathr@mail.ru
Я сделала все Ваши добавки, но не работает на 8.3
51. XSlava 142 03.03.17 12:08 Сейчас в теме
Пришлите мне файл который вы доработали, я его проверю на 8.3 и поправлю если не будет работать.
Оставьте свое сообщение

См. также

Универсальная выгрузка/загрузка данных для отличающихся конфигураций (JSON, Такси+ОФ) Промо

Перенос данных из 1C8 в 1C8 Универсальные обработки Распределенная БД (УРИБ, УРБД) v8 1cv8.cf Абонемент ($m)

Простой перенос через JSON данных между двумя базами 1С (документов, справочников, ПВХ, ПВР, счетов). Аналогична произвольной выгрузке в типовой "Выгрузка/загрузка XML", но может использоваться для отличающихся конфигураций. Подходит для любых пар баз с любым интерфейсом (управляемый + обычный). Без настроек. Не требует идентичности конфигураций и платформ. При переносе типы данных сопоставляются по наименованиям метаданных, объекты и ссылки по UID.

1 стартмани

22.10.2014    199928    3056    ekaruk    178    

Конвертация данных 2. Использование исходящих и входящих данных. Свойство "Получить из входящих данных"

Обмен данными 1С Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Разработка правил обмена с использованием исходящих и входящих данных. В качестве примера рассмотрена реальная задача конвертации номенклатуры через регистр сопоставления номенклатур. Статья предназначена в первую очередь для тех, кто только начинает осваивать Конвертацию данных.

17.02.2020    8014    0    Drivingblind    24    

Самописный обмен данными через веб сервис маленькими пакетами с большой скоростью

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Абонемент ($m)

Подсистема в конфигурацию 1С, обеспечивающая обмен данными по настраиваемым правилам в разные системы 1С. Обмен осуществляется сообщениями через сервис. Разработка и тестирование на версии 8.3.15.1656

10 стартмани

06.02.2020    3867    3    visork    12    

Универсальный обмен данными между идентичными конфигурациями, версия 2020.3.1

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка «Универсальная выгрузка и загрузка» предназначена для оперативного переноса объектов между двумя идентичными или похожими конфигурациями. Быстрая, надежная и очень простая в использовании обработка.

1 стартмани

29.01.2020    6282    98    vladnet    22    

Перенос объектов 1С Промо

Перенос данных из 1C8 в 1C8 v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой и наглядный перенос объектов между любыми базами 1С 8 с предварительным анализом на возможные различия в данных (через файл, через интернет, через буфер обмена). Интерактивная настройка правил обмена на стороне источника и получателя. В обработке есть удобный обзор по подсистемам, поиск и обработка данных по заданному фильтру. Сравнение объектов, поиск ссылок. Конструктор кода по созданию объектов, написание скриптов и отладка мини-функций в УФ. Отключение/включение регламентных заданий. Регистрация/снятие с регистрации объектов в планах обмена. И многое другое. Инструменты администратора в одной обработке.

1 стартмани

16.03.2015    85473    1371    moolex    193    

Отладка правил обмена КД2 для подсистемы БСП Обмен данными

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Уже давно нельзя отлаживать правила обмена при помощи внешних файлов. Попробуем исправить это.

1 стартмани

27.05.2019    10450    10    fenixnow    5    

Выгрузка и загрузка данных XML с гибкими отборами

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка выгрузки и загрузки данных через XML между идентичными конфигурациями с возможностью установки произвольных отборов на выгружаемые объекты.

1 стартмани

07.04.2019    13599    346    sapervodichka    7    

Слияние баз ERP (формирование остатков и перенос данных)

Обработка документов Перенос данных из 1C8 в 1C8 v8 ERP2 Абонемент ($m)

Обработка формирует в базе Источника документы ввода остатков на складах, в производстве, по ОС и НМА, остатки по счетам БУ, остатки по ЗУП. Далее в базу Приемник правилами обмена переносятся данные: НСИ, Заказы, Вводы остатков, Вводы остатков внеоборотных активов, Операции бух., Корректировка регистров, Данные ЗУП (Остатки ЗУП, НСИ, документы за период). Проверялось между 1C ERP 2.2.4.158 1С ERP 2.4.6.160.

5 стартмани

25.03.2019    6773    22    sapervodichka    6    

Соответствия объектов обмена Промо

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 КА1 Россия Абонемент ($m)

Обработка позволяет проверять, исправлять ошибки, добавлять и удалять соответствия объектов в обменах данными между конфигурациями на основе «Комплексной автоматизации 1.1» или похожими конфигурациям. Подходит для обменов с использованием регистра сведений «СоответствиеОбъектовДляОбмена».

2 стартмани

26.08.2016    19406    11    xxxelaaa    0    

Перенос данных КА 1.1 -> КА 2

Перенос данных из 1C8 в 1C8 Обмен через XML v8 КА1 КА2 Россия Абонемент ($m)

Перенос данных КА 1.1 => КА 2 с помощью правил обмена данными в формате XML КД 2 (переносятся остатки, документы, справочная информация).

5 стартмани

20.03.2019    13007    236    gudogu    127    

Ручная выгрузка и загрузка данных через универсальный обмен данными с настройками (расширение, платформа 8.3+)

Обработка документов Обработка справочников Обмен через XML Перенос данных из 1C8 в 1C8 v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Данное расширение (не требует изменения конфигураций) служит как надстройка для конфигураций, у которых обмен между базами происходит через универсальный формат (EnterpriseData), с использованием стандартных правил конвертации, которые уже есть в конфигурации. Интерфейс адаптирован для простых пользователей, сделан общий отбор по Организации для всех документов, имеется пару настроек для передачи в параметры конвертации, которые расположены в общем модуле конфигураций, а так же есть возможность выбора запуска - в фоне или в текущем сеансе. Теперь не нужно настраивать обмен между базами, для того чтоб просто перенести нужные документы. Подходит точно для УТ 11.4, БП 3.0.67, КА 2.4.5, Розница 2.2.9 (Обновление 1.2 от 02.03.2019)

2 стартмани

19.01.2019    17647    116    hakerxp    10    

Обмен без правил. От простого к сложному

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Пишем обмен с нуля, разбираемя с разными способами сериализации, учимся редактировать XML документы, создаем XDTO и Web service, осваиваем Script variant - English.

1 стартмани

16.01.2019    20207    14    fr13    26    

Перенос данных КА 1.1.115.1 => БП 3.0.75.104 (перенос остатков, документов, зарплатный блок и справочной информации)

Перенос данных из 1C8 в 1C8 Обмен через XML v8 КА1 БП3.0 Россия Абонемент ($m)

Переносятся: остатки по счетам 01, 02, 10, 20, 41, 60, 62, 71, 97 и их субсчетам; документы; отдельно можно перенести справочники (номенклатура, контрагенты, договоры контрагентов, организации, склады, физические лица, сотрудники).

5 стартмани

22.12.2018    11194    315    gudogu    152    

Выполнение запроса в другой базе 1С без com-соединения. HTTP-сервис

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Выполнение любого запроса с параметрами из одной базы 1С в другую. Используя HTTP-сервис. Посредством POST-запроса и JSON.

1 стартмани

30.11.2018    17008    20    John_d    21    

Пример получения данных из другой базы 1С через Web-сервис

Перенос данных из 1C8 в 1C8 v8 Россия Абонемент ($m)

В данной статье описан пример получения данных справочника из другой базы 1С через Web-сервис.

1 стартмани

11.11.2018    23514    21    flyDrag    29    

Выгрузка данных из УТ 10.3 в БП 3.0 (своими руками) Промо

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия Абонемент ($m)

Старая добрая, позабытая многими выгрузка из УТ 10.3 в БП 1.6. Ее еще можно оживить, и она послужит на благо всем желающим, всем уставшим от автоматических обменов.

3 стартмани

30.10.2014    37203    175    TESL    40    

Способы оптимизации переносов данных

Перенос данных из 1C8 в 1C8 Интеграция v8 КД Абонемент ($m)

Хочу рассказать вам про способы оптимизации разработки правил обмена в программе «Конвертация данных» второй редакции. Казалось бы, про эту программу и разработку в ней правил конвертации уже сказано все, что можно. Появились уже более современные и быстрые технологии. Почему же все еще она? Дело в том, что «Конвертация данных» второй редакции все еще актуальна для огромного круга задач. Она имеет очень широкую функциональность и позволяет реализовывать сложные алгоритмы. Годы идут, а люди продолжают ей пользоваться и у них возникает много вопросов по этой программе. Возможно, в будущем вы тоже будете заниматься такими проектами и столкнетесь с задачами, похожими на те, про которые я собираюсь рассказать. Мне хочется вам в этом помочь.

1 стартмани

02.08.2018    15648    11    primat    7    

Опыт проведения сложных переносов данных на 1С

Перенос данных из 1C8 в 1C8 Интеграция v8 КД Абонемент ($m)

В статье я расскажу про опыт сложных переносов на платформе 1С:Предприятие. Она будет адресована в первую очередь разработчикам 1С, которые уже имеют опыт использования методики «Конвертация данных» (как второй, так и третьей редакции) – я думаю, это большинство из нас. • Я расскажу про различные методики организации переносов данных. • Мы рассмотрим рекомендуемые способы оптимизации правил конвертации, которые позволят вам быстрее выполнять свои переносы. • Также мы разберем, какие могут возникнуть сложности в ходе переноса данных. • Я покажу сравнительный анализ по ряду параметров инструментов «Конвертация данных» второй редакции и третьей, которая вышла уже более года назад.

1 стартмани

30.07.2018    33281    8    primat    13    

Интерфейс сопоставления объектов для обмена (для типового регистра СоответствиеОбъектовДляОбмена) Промо

Инструментарий разработчика Универсальные обработки Перенос данных из 1C8 в 1C8 v8 КА1 БП2.0 ЗУП2.5 УТ10 УПП1 Абонемент ($m)

Вы внедряете обмен данными между двумя типовыми или основанными на типовых БД и вам необходим инструмент, чтобы сопоставить между собой справочники этих конфигураций? Вы хотите навести порядок в обмене данными, потому что вам надоело вылавливать дублирующиеся объекты? Вам очень хочется перепоручить сопоставление объектов обменивающихся баз пользователям, но нет подходящего и понятного пользователям интерфейса? Тогда вам нужна именно эта обработка!

4 стартмани

11.11.2015    35957    131    catsam    8    

Конвертация данных 2.1. Как реквизит справочника конвертировать в регистр сведений?

Перенос данных из 1C8 в 1C8 v8 КД Россия Абонемент ($m)

В публикации рассмотрен пример конвертации реквизита справочника в регистр сведений.

2 стартмани

28.06.2018    12449    2    wowik    0    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Обмен через XML Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов, справочников и планов видов расчета из конфигурации 1С ЗУП 2.5 в ЗУП 3.1.

3 стартмани

28.03.2018    25820    408    Cobranet123    64    

Настройка соответствий подразделений ЗУП 3.1 и БП 3.0

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Синхронизация ЗУП 3 и БП 3.0: настройка соответствий подразделений при помощи внешней обработки.

5 стартмани

23.03.2018    21988    159    pas    26    

Синхронизация (выгрузка) данных ЗУП 3.1 - БП 2.0, УПП 1.3

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП2.0 ЗУП3.x Россия БУ Абонемент ($m)

Подобная выгрузка не была предусмотрена разработчиками 1С, поэтому и существует эта публикация. Поддерживается выгрузка оценочных обязательств и резервов отпусков. Непосредственная выгрузка в базу Бухгалтерии. Решение проблем с COM-соединением одной кнопкой.

3 стартмани

22.03.2018    36739    617    diso    178    

Перенос данных из конфигурации "Зарплата и управление персоналом" 3.1 в "Бухгалтерию предприятия" 2.0

Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

Перенос данных по Ole Automation из ЗУП 3.1 в БП 2.0. Тестировался на релизах 2.0.66.46 и 3.1.2.483.

3 стартмани

15.03.2018    11887    20    roma_semenov79    0    

Дозагрузка кадровых документов в ЗУП 3.1 из ЗУП 2.5 в интерактивном режиме

Перенос данных из 1C8 в 1C8 Управление персоналом (HRM) Обработка документов Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Обработка для интерактивной "дозагрузки" кадровых документов в ЗУП 3.1 из ЗУП 2.5 являвшейся источником для переноса данных. Как правило, перенос данных из 2.5 в 3.1 осуществляется как перенос остатков на определенную дату. Созданные после этой даты в ЗУП 2.5 документы обычно распроводятся и при переносе не участвуют. Обработка используется для последующей дозагрузки таких документов. Загрузка происходит в интерактивном режиме подокументно. Т.е. собственно "загрузки" как таковой не происходит - происходит заполнение формы документа данными из ЗУП 2.5.

5 стартмани

01.03.2018    17837    152    rilmir    21    

Проверка данных после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1 Промо

Зарплата Бухгалтерский учет Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Описаны данные, которые необходимо проверить после неполного ("нового") переноса из ЗУП 2.5 в ЗУП 3.1. Описано, на что необходимо обратить внимание, где найти перенесенные данные, что НЕ переносится, где найти настройки.

1 стартмани

17.01.2018    26649    141    btydj    3    

Организация обмена с базой филиала (розничного магазина) в торговой сети через XML (универсальный обмен)

Обмен через XML Перенос данных из 1C8 в 1C8 Розничная торговля Розничная торговля v8 КД УТ11 Розничная и сетевая торговля (FMCG) Абонемент ($m)

В статье по шагам рассматривается создание обмена между центральной базой и базами филиалов на базе конфигурации УТ 11. Для решения поставленной задачи было решено не использовать РИБ, т.к. требуется односторонний обмен ограниченным набором данных, к тому же по определенным условиям. Обмен реализован на основе типовой синхронизации на основе универсального обмена в формате EnterpriseData. Данная публикация может быть полезна внедренцам, которые работают с торговыми сетями, в том числе по модели франчайзинга.

1 стартмани

26.02.2018    34155    13    Kutuzov    18    

[УТ 11][БП 3.0] Перенос данных из БП 3.0 в УТ 11 (начальное заполнение УТ 11 по данным БП 3.0)

Перенос данных из 1C8 в 1C8 v8 БП3.0 УТ11 Россия УУ Абонемент ($m)

Перенос данных из БП 3.0 в Ут 11 для первоначального заполнения УТ данными из БП. 31.01.2020 Версия 2.8.7.0 БП 3.0.75.70 платформа 8.3.16.1148. Исправлено подключение COM, более ничего...и это-то по многочисленным просьбам трудящихся... Нет пока времени (ну, или клиента) чтобы заняться этой обработкой...

1 стартмани

29.01.2018    35165    456    Alex_E    144    

Перенос данных. Правила конвертации из УТ 10.3 в УТ 11.4

Перенос данных из 1C8 в 1C8 Обмен через XML v8 УТ10 КД УТ11 Россия Абонемент ($m)

Правила конвертации из УТ10.3(10.3.32.2) в  УТ11.4(11.4.1.261) (для переноса остатков, справочников)

2 стартмани

02.01.2018    43616    349    appolon321    36    

Выгрузка - загрузка данных в XML с отбором по организации Промо

Обмен через XML Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Выгрузка - загрузка данных в XML с отбором по организации (УФ)

1 стартмани

25.05.2014    44333    297    buganov    42    

Конвертация данных: Поиск при загрузке по дополнительному реквизиту

Перенос данных из 1C8 в 1C8 v8 УТ10 КД БП3.0 Абонемент ($m)

Конвертация данных 2.1. Поиск при загрузке справочника по дополнительному реквизиту.

1 стартмани

13.12.2017    14628    4    vowg    12    

Правила переноса документов из ЗУП 2.5 в ЗУП 3.1

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Перенос документов из ЗУП 2.5 в ЗУП 3.1 - позволяет снизить объем работ при опытной эксплуатации ЗУП 3.1 параллельно с ЗУП 2.5.

1 стартмани

04.12.2017    30153    494    AntonH851    38    

Пример создания в КД 2.1 правил выгрузки данных регистра «Лицевые счета работников» из ЗУП 2.5 в справочник «Банковские счета» БП 3.0. Подробно, ясно и просто.

Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Эту статью я написал для тех, кто хочет максимально быстро и эффективно научиться создавать правила выгрузки данных в конфигурации 1С Конвертация данных редакции 2.1. Разберем практическую несложную задачу создания правил выгрузки данных регистра «Лицевые счета работников организаций» ЗУП 2.5 в справочник «Банковские счета» БП КОРП 3.0. Поделюсь некоторыми эффективными приемами: ВыгрузкаПоПравилу(…), работа с глобальными параметрами конвертации и передача их с Источника в Приемник методом ПередатьОдинПараметрВПриемник(…), приемы ускорения и оптимизации конвертации данных. Кому эта статья покажется простой и/или захочется продолжения: рекомендую другую мою публикацию, в которой разобран более сложный пример : https://infostart.ru/public/695916/

1 стартмани

17.11.2017    34096    15    RailMen    1    

Перенос справочников и документов из УТ 10.3 в БП 3.0 Промо

Перенос данных из 1C8 в 1C8 v8 УТ10 БП3.0 Россия БУ НУ УУ Абонемент ($m)

Синхронизация справочников и документов из Управление торговлей 10.3 в Бухгалтерию предприятия 3.0. Обработка не затрагивает штатный механизм. Подключение и перенос документов происходит посредством OLE. Без ввода начальных остатков.

10 стартмани

25.07.2017    20030    14    2casp    5    

1С:Конвертация данных 2.0. Анализ состава выгруженных данных из базы источника до загрузки в базу-приемник

Перенос данных из 1C8 в 1C8 Перенос данных из 1С7.7 в 1C8.X v8 КД БП3.0 ЗУП3.x Россия Абонемент ($m)

Обработка анализирует файл выгрузки данных конвертации и формирует дерево выгруженных объектов по категориям с возможностью просмотра выгруженных реквизитов (свойств). Идеально подходит для анализа выгруженных данных при переходе на ЗУП 3.1 или Бухгалтерия 3.0 с ранних версий.

1 стартмани

16.11.2017    14153    80    leosoft    4    

Механизмы и транспорт обмена данными. Пример создания в КД 2.1 правил обмена данными ЗУП 2.5 -> БП 3.0. Выгрузка ведомостей и банковских счетов. Передача параметров обмена из Источника в Приемник. ВыгрузитьПоПравилу(). ПередатьОдинПараметрВПриемник().

Обмен через XML Перенос данных из 1C8 в 1C8 v8 ЗУП2.5 КД БП3.0 Абонемент ($m)

В статье рассказываю: 1) о механизмах и транспорте обмена данными, где одной из сторон обмена выступает конфигурация на базе 1С, и о том, какой транспорт и в каких случаях лучше использовать 2) о решении задачи выгрузки данных документа «Зарплата к выплате организаций» (с выгрузкой банковский счетов физ лиц документа) из ЗУП 2.5.123.1 (далее Источник) в БП КОРП 3.0.52.39 (далее Приемник) путем создания правил обмена данными с использованием конфигурации «Конвертация данных» (далее просто КД) ред. 2.1.8.2. для (далее ЗкВО) 3) о тестирование полученных правил обмена данными.

1 стартмани

03.11.2017    29914    5    RailMen    5    

Перенос данных УПП/КА в ЕРП и КА2, что таит этот чудный процесс

Перенос данных из 1C8 в 1C8 v8 КА1 УПП1 ERP2 КА2 Россия Абонемент ($m)

По итогам нескольких переносов УПП/КА в ЕРП и КА появилась данная статья. Не так счастлив этот процесс и его результаты.

1 стартмани

20.09.2017    23377    68    Константин С.    21    

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1 Промо

Обмен через XML Зарплата Перенос данных из 1C8 в 1C8 Зарплата v8 v8::СПР ЗУП2.5 ЗУП3.x Россия БУ Абонемент ($m)

Правила конвертации документов ЗУП 2.5 - ЗУП 3.1. Позволяют вести параллельную работу в базах ЗУП редакций 2,5 и 3.1.

10 стартмани

06.03.2018    35026    151    kostya_whiskas    24    

Синхронизация данных по правилам КД2.0

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Новый инструмент для сравнения и загрузки данных, сочетающий в себе: гибкость запросов (используются для сопоставления объектов); наглядный вывод отличий; удобный отбор загружаемых данных; возможность пообъектной синхронизации двух баз по правилам КД2 с помощью вызова обработки "Универсальный обмен XML" в базе-источнике через COM-соединение.

1 стартмани

27.08.2017    21736    109    vikad    35    

Правила обмена ЗУП 3.1 - БП 2.0 и ЗУП 3.1 - УПП 1.3 (отражение, ведомости и справочники)

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ v8::СПР БП2.0 БП3.0 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для выгрузки документов "Отражение зарплаты в бухучете", "Ведомость в банк", "Ведомость в кассу", справочников "Сотрудники" и "Физические лица"

1 стартмани

01.08.2017    72149    1533    forseil    205    

«Горыныч - то НЕ НАСТОЯЩИЙ!» … или О Конвертации Данных ред.3 (КД 3) и обменах в универсальном формате Enterprise Data… доступным русско-народным языком

Внешние источники данных Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Тем, кто хочет быстро разобраться с темой инструмента Конвертация данных 3.0 и технологией обмена по новому формату 1С, активно применяемому во всех новых конфигурациях от 1С на БСП, расширяющем возможности интеграции, пакет полезных материалов.

1 стартмани

13.06.2017    19279    138    Davlad_A    16    

Перенос НФА (ОС и МЗ) между учреждениями/базами через документы списания и поступления [БГУ 1.0] Промо

Перенос данных из 1C8 в 1C8 Обработка документов Учет ОС и НМА Учет ОС и НМА v8 v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Обработка выполняет перенос основных средств/материалов между учреждениями/базами через документы списания НФА и безвозмездного получения в другом учреждении/базе данных.

10 стартмани

18.09.2014    38789    46    qwinter    31    

Обмен данными между программами "1С: Бухгалтерия предприятия" редакция 2.0 и "1С: Зарплата и управление персоналом" редакция 3.1

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::БУ БП2.0 Россия БУ Абонемент ($m)

В связи с отсутствием типовых правил обмена между конфигурациями БП 2.0 и ЗУП 3.1 (3.0) предлагается действующее решение в виде внешней обработки. Алгоритм построен на прямом подключении из базы БП к базе ЗУП. Для переноса данных используется COM-соединение с обработкой COM-объектов базы источника на стороне базы приемника.. Используется односторонний обмен - данные из ЗУП переносятся в БП.

1 стартмани

17.04.2017    24663    241    ivanovmi    37    

Правила обмена ЗУП 3.1(3.1.2.140) - УПП 1.3(1.3.88.2) - документа "Отражение зарплаты в регламентированном учете". Добавлено правило Отражения ERP20->БП30. ***Добавлено правило для ЗУП 3.1.5 и старше с использованием дополнительных реквизитов.

Перенос данных из 1C8 в 1C8 Зарплата Зарплата v8 УПП1 ЗУП3.x Россия БУ Абонемент ($m)

Правила обмена для производственных предприятий, где зарплата отдельной программой ЗУП 3.1 (для оперативного поддержания актуальности релиза), а управленческий и регламентированный учет ведется в УПП 1.3.

1 стартмани

24.03.2017    22364    213    bulas    51    

Перенос объектов по OLE из идентичной конфигурации

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Абонемент ($m)

Перенос по OLE справочников, документов и пользователей из базы источника с идентичной конфигурацией без использования правил обмена, поиск по реквизитам, замена ГУИД, сохранение настроек в файл

1 стартмани

10.07.2016    14307    120    slava_1c    8    

Выгрузка/загрузка данных в формате JSON v 1.0.6 Промо

Распределенная БД (УРИБ, УРБД) Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

Обработка предназначена для обмена данными между схожими конфигурациями в формате JSON. Этот формат обладает рядом существенных преимуществ по сравнению с xml и прочими популярными форматами. В отличие от существующих аналогов, обработка не использует никаких дополнительных библиотек. (де)Сериализация всех объектов происходит средствами встроенного языка и методов ЗаписатьJSON() и ПрочитатьJSON(). Работает на платформе версии не ниже 8.3.6.

3 стартмани

27.01.2016    41497    321    kser87    41    

Правила обмена УТ 11 -> УНФ 1.6

Перенос данных из 1C8 в 1C8 v8 УТ10 УНФ Абонемент ($m)

Потребовалось перевести работу из УТ 11 на УНФ 1.6 с переносом данных, введенных с начала года. Типовые правила отсутствуют, поэтому разработали собственные. Замечу, что правила не универсальные, т.е. не подстраиваются под разные учетные политики, вероятно, некоторые моменты вам придется поменять, но на 90% они подойдут (Конфигурации УТ 11.1.10.185 и УНФ 1.6.5.28) После переноса документы нужно будет провести. (Меню 1С - Все функции - Стандартные - Проведение документов - Провести все ранее проведенные)

2 стартмани

09.06.2016    26709    125    sapervodichka    16    

Перенос данных из ЗУП 2.5 в ЗУП 3.1

Перенос данных из 1C8 в 1C8 Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 ЗУП3.x БУ Абонемент ($m)

Обработка предназначена для переноса некоторых данных из ЗУП 2.5 в ЗУП 3.1 через COM-соединения. Обработка была написана потому, что типовые правила переноса не предоставляют возможности переносить данные по отдельности, а некоторые данные не переносят вовсе. Тестировалась на версии 3.1.12.113 (8.3.15.1830).

1 стартмани

26.05.2016    40186    734    yojeeg    90    

[COM] Перенос данных через COMConnector

Перенос данных из 1C8 в 1C8 v8 1cv8.cf Россия Абонемент ($m)

Обработка обмена между двумя информационными базами схожей (не обязательно совпадающей) структуры. Изначально была заточена под бухгалтерию предприятия, сейчас используется для для обменов через COM любых конфигураций с режимом запуска "Управляемое приложение". Ближайший аналог - выгрузка-загрузка XML, но здесь нет промежуточных файлов выгрузки/загрузки, и обмен не прекращается в случае, когда состав реквизитов источника и приёмника различен!!! 22.05.2020 Версия 5.2.3.4 Исправлена ошибка в таблице соответствия планов счетов, любезно подсказанная Fox_65. Все реквизиты таблицы соответствия теперь с типом строка, чтобы избежать в дальнейшем повторения этой ошибки, если обработку вдруг будет сохранена в конфигурации, не имеющей Плана счетов Хозрасчтный. Соответственно изменены заполнеие таблицы соответствия счетов и поиск счетов между базами. Из нового - добавлен возможность переноса Счетов на оплату покупателю из КА 1.1 в Заказ клиента КА 2.4 (случилась такая хотелка у клиента) (тестировалось на платформе 8.3.17.1386, БП 3.0.77.89 )

2 стартмани

23.11.2015    46130    630    Alex_E    201    

Штатный перенос данных ЗУП 2.5 -> ЗУП 3.0 в режиме отладки

Перенос данных из 1C8 в 1C8 Обмен через XML Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 ЗУП2.5 ЗУП3.x Абонемент ($m)

Штатный переход ЗУП 2.5 -> ЗУП 3.0 завершается при наличии ошибок в конвертации данных. Если механизм немного подправить, то можно обойти это ограничение. Назовем это режимом отладки. В итоге получим внешнюю обработку которая осуществит переход и просто сообщит о наличии ошибок конвертации данных.

1 стартмани

24.09.2015    22492    61    duhh    6