Загрузка из Excel с выбором листа на управляемых формах

Публикация № 1730940 21.09.22

Пользовательские инструменты - Загрузка и выгрузка в Excel

excel йоксель уф управляемые формы выбор листа загрузка чтение клиент сервер клиент-сервер

В помощь тем, кому нужно быстро реализовать кнопку загрузки из Excel на управляемых формах платформы 1С 8.3.

Для работы этого способа необходимо чтобы на компьютере пользователя был установлен MS Excel.

1) Создайте пустую форму и отредактируйте её модуль

`

 


///*
//* Copyright (c) 2022, Ilham Djumatov. All rights reserved.
//* Copyrights licensed under the GNU GPLv3.
//* See the accompanying LICENSE file for terms.
//*/

&AtClient
Var ExcelApp;
&AtClient
Var Book;
&AtClient
Var Sheet;

&AtServer
Procedure OnCreateAtServer(Cancel, StandardProcessing)
    
    // Реквизиты формы
    AttributesToAdd = New Array;
    AttributesToAdd.Add(New FormAttribute("FirstRow",     New TypeDescription("Number", New NumberQualifiers(10, 0)), ""));
    AttributesToAdd.Add(New FormAttribute("FirstCol",     New TypeDescription("Number", New NumberQualifiers(10, 0)), ""));
    AttributesToAdd.Add(New FormAttribute("LastRow",      New TypeDescription("Number", New NumberQualifiers(10, 0)), ""));
    AttributesToAdd.Add(New FormAttribute("LastCol",      New TypeDescription("Number", New NumberQualifiers(10, 0)), ""));
    AttributesToAdd.Add(New FormAttribute("List",         New TypeDescription("ValueList"), ""));
    ChangeAttributes(AttributesToAdd);
    
    Parameters.Свойство("FirstRow",     ThisObject["FirstRow"]);
    Parameters.Свойство("FirstCol",     ThisObject["FirstCol"]);
    Parameters.Свойство("LastRow",      ThisObject["LastRow"]);
    Parameters.Свойство("LastCol",      ThisObject["LastCol"]);
    
    If ThisObject["FirstRow"] = 0 Then
        ThisObject["FirstRow"] = 1;
    EndIf;
    
    If ThisObject["FirstCol"] = 0 Then
        ThisObject["FirstCol"] = 1;
    EndIf;
    
    ThisForm.CommandBar.Visible = False;
    ThisForm.Title = "Выберите лист";
    ThisForm.AutoTitle = False;
    ThisForm.WindowOpeningMode = FormWindowOpeningMode.Independent;
    
    Item = Items.Add("List", Type("FormTable"));
    Item.DataPath = "List";
    Item.ReadOnly = True;
    Item.CommandBar.Visible = False;
    Item.SetAction("Selection", "ListSelection");
    
    Item = Items.Add("ListValue", Type("FormField"), Items["List"]);
    Item.DataPath = "List.Value";
    
EndProcedure

&AtClient
Procedure ListSelection(Item, SelectedValue, Field, StandardProcessing)
    
    Status("Выполняется чтение данных");
    
    FirstRow = ThisObject["FirstRow"];
	FirstCol = ThisObject["FirstCol"];
	LastRow = ThisObject["LastRow"];
	LastCol = ThisObject["LastCol"];
    
    WorksheetNumber = Item.CurrentData.Value;
    Try // Открываем лист
        Sheet = Book.WorkSheets(WorksheetNumber);
    Except
        ShowMessageBox(, "Не удалось открыть лист.");
        Return;
    EndTry;
    
    // Определение версии EXCEL.
    Version = Left(ExcelApp.Version,Найти(ExcelApp.Version,".")-1);
    ColCount = 0;
    RowCount = 0;
    If Version = "8" Then
        ColCount = Sheet.Cells.CurrentRegion.Columns.Count;
        RowCount = Sheet.Cells.CurrentRegion.Rows.Count;
    Else 
        // Метод SpecialCells не отображает только количество в области
        // если в области несколько областей, то количество получится неверным
        //ColCount = Sheet.Cells.SpecialCells(11).Column;
        //RowCount = Sheet.Cells.SpecialCells(11).Row;
        
        // Метод UsedRange количество использованных ячеек
        // если первая стрчка или колонка пропущены и то они не будут включаться в количество
        ColCount = Sheet.UsedRange.Columns.Count;
        RowCount = Sheet.UsedRange.Rows.Count;
        
        // Вычисляем правильное количество колонок и строк
        ColCount = Sheet.UsedRange.Column + Sheet.UsedRange.Columns.Count-1;
        RowCount = Sheet.UsedRange.Row + Sheet.UsedRange.Rows.Count-1;
    EndIf;
    
    If LastCol = 0 Then
        LastCol = ColCount;
    ElsIf ColCount < LastCol Then // не хватает колонок //Увеличение проверочного числа (как и захваченной области в самих документах) на дополнительные колонки
        ShowMessageBox(, "В файле не хватает колонок.");
        Return;
    EndIf;
    
    If LastRow = 0 Then
        LastRow = RowCount;
    ElsIf RowCount < LastRow Then // не хватает строк
        ShowMessageBox(, "В файле не хватает строк.");
        Return;
    EndIf;
    
    Range = Sheet.Range(Sheet.Cells(FirstRow,FirstCol), Sheet.Cells(LastRow,LastCol));
    Data = Range.Value.Unload();
    
    NotifyChoice(Data);
    
EndProcedure

&AtClient
Procedure OnOpen(Cancel)
    
    Dialog = New FileDialog(FileDialogMode.Open);
    Dialog.Title = "Выберите файл";
    Dialog.FullFileName = "";
    Dialog.Filter = "Excel документ (*.xls/*.xlsx)|*.xls?";
    Dialog.Multiselect = False;
    Dialog.Directory = "С:\";
    
    Notify = New NotifyDescription("ProcessFileSelection", ThisObject);
    Try
        BeginPuttingFiles(Notify,Dialog, True);
    Except
        ErrorDescription = ErrorDescription();
        ErrorInfo = ErrorInfo();
        If Find(ErrorDescription, "32(0x00000020)") > 0 Then 
            ShowMessageBox(, "Ошибка совместного доступа к файлу. Пожалуйста сперва закройте файл.");
        Else 
            ShowMessageBox(, ErrorDescription);
        EndIf;
        Cancel = True;
    EndTry;
    
    If Dialog.SelectedFiles.Count() = 0 Then 
        Cancel = True;
    EndIf;
    
EndProcedure

&AtClient
Procedure ProcessFileSelection(Files, Params) Export 
    If Files <> Undefined Then 
        For Each TransferedFileDescription In Files Do 
            File = New File(TransferedFileDescription.FullName);
            Notify = New NotifyDescription("ProcessFile", ThisObject, File);
            File.НачатьПроверкуСуществования(Notify);
        EndDo;
    Else 
        Close();
    EndIf;
EndProcedure

&AtClient
Procedure ProcessFile(Exists, File) Export 
    
    If Exists Then
        
        Status("Выполняется чтение листов");
        
        FilePath = File.FullName;
        
        Try
            ExcelApp = New COMОбъект("Excel.Application");
        Except
            Закрыть();
            Return;
        EndTry;
        
        ExcelApp.DisplayAlerts = False;
        ExcelApp.FileValidation = 1;
        
        Try // Открываем файл
            Book = ExcelApp.Workbooks.Open(FilePath);
        Except
            // Debug
            ErrorInfo = ErrorInfo();
            ErrorDescription = ErrorDescription();
            // App
            ExcelApp.Quit();
            ExcelApp = NULL;
            Close();
            Return;
        EndTry;
        
        For SheetNumber = 1 To Book.WorkSheets.Count Do
            ThisObject["List"].Add(SheetNumber, Book.WorkSheets(SheetNumber).Name);
        EndDo;
    Else 
        ShowMessageBox(, "Файл не найден: " + File.FullName);
        Close();
    EndIf;
    
EndProcedure

&AtClient
Procedure BeforeClose(Cancel, Exit, MessageText, StandardProcessing)
    
    If Book <> Undefined Then
        Try
            Book.Close();
        Except
            // Debug
            ErrorInfo = ErrorInfo();
            ErrorDescription = ErrorDescription();
        EndTry;
    EndIf;
    Book = NULL;
    
    // App
    If ExcelApp <> Undefined Then
        Try
            ExcelApp.Quit();
        Except
            // Debug
            ErrorInfo = ErrorInfo();
            ErrorDescription = ErrorDescription();
        EndTry;
    EndIf;
    ExcelApp = NULL;
    
EndProcedure

// Прикрепим обработчики событий
#If Server Then
ThisForm.SetAction("OnCreateAtServer", "OnCreateAtServer");
ThisForm.SetAction("OnOpen", "OnOpen");
ThisForm.SetAction("BeforeClose", "BeforeClose");
#EndIf

 

 

2) Протестируйте загрузку

 

 


&НаСервере
Процедура ЗагрузкаНаСервере(МассивКолонкиСтроки)
    
    // Мы знаем с какой строчки начинаются данные в загружаемом шаблоне
    Для НомерСтроки = 3 По МассивКолонкиСтроки[0].Количество() Цикл 
        
        // Мы знаем в каких колонках содержатся данные в загружаемом шаблоне
        Знч1 = МассивКолонкиСтроки[1-1][НомерСтроки-1]; // Значение R{ИндексСтроки}C1
        Знч2 = МассивКолонкиСтроки[2-1][НомерСтроки-1]; // Значение R{ИндексСтроки}C2
        Знч3 = МассивКолонкиСтроки[3-1][НомерСтроки-1]; // Значение R{ИндексСтроки}C2
        
        // Если в указанной ячейке нету данных то пропускаем эту строчку
        Если ПустаяСтрока(Знч1) Тогда 
            Продолжить;
        КонецЕсли;
        
        Сообщить("" + Знч1 + Символы.Таб + Знч2 + Символы.Таб + Знч3);
        
    КонецЦикла;
    
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаКомандыЗагрузка(Результат, Параметры) Экспорт 
    
    Если Результат = Неопределено Тогда 
    ИначеЕсли ТипЗнч(Результат) = Тип("Массив") Тогда 
        // Проверяем количество колонок в загружаемом шаблоне
        Если Результат.Количество() < 3 Тогда 
            ПоказатьПредупреждение(,"Ошибка! В файле не хватает колонок.");
        Иначе
            // Проверяем определённые ячейки загружаемого шаблона
            ШаблонПодходит = Истина;
            ШаблонПодходит = ШаблонПодходит И Найти(Результат[01-1][2-1], "Сотрудник") > 0;
            ШаблонПодходит = ШаблонПодходит И Найти(Результат[02-1][2-1], "Должность") > 0;
            ШаблонПодходит = ШаблонПодходит И Найти(Результат[03-1][2-1], "Оклад") > 0;
            Если ШаблонПодходит Тогда 
                ЗагрузкаНаСервере(Результат);
                ПоказатьПредупреждение(, "Готово!");
            Иначе 
                ПоказатьПредупреждение(, "Выбран не корректный файл для загрузки.");
            КонецЕсли;
        КонецЕсли;
    Иначе 
        ПоказатьПредупреждение(, "Загрузка не поддерживается.");
    КонецЕсли;
    
КонецПроцедуры

&НаКлиенте
Процедура Загрузка(Команда)
    П = Новый Структура;
    Оповещение = Новый ОписаниеОповещения("ОбработкаКомандыЗагрузка", ЭтотОбъект);
    ОткрытьФорму("ВнешняяОбработка.БыстраяЗагрузкаИзExcel.Форма.ФормаЧтенияExcel", П,,,,, Оповещение, РежимОткрытияОкнаФормы.БлокироватьВесьИнтерфейс);
КонецПроцедуры

 

 

Тестировалось на платформе 1С:Предприятие 8.3 (8.3.16.1224).

Скачать файлы

Наименование Файл Версия Размер
Загрузка из Excel с выбором листа на управляемых формах:

.epf 10,58Kb
1
.epf 10,58Kb 1 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. ivnik 527 27.09.22 09:52 Сейчас в теме
Где обработка берет файл для загрузки? На скринах не увидел поля выбора загружаемого файла....
2. idjumatov 11 27.09.22 10:52 Сейчас в теме
(1) Выбор файла осуществляется стандартным диалогом выбора файла
3. ivnik 527 27.09.22 19:45 Сейчас в теме
(2)
(2)Это понятно, просто на скринах не увидел поля выбора загружаемого файла. Диалог возникает при открытии обработки?
4. idjumatov 11 28.09.22 07:08 Сейчас в теме
(3) Диалог возникает при открытии формы

&AtClient
Procedure OnOpen(Cancel)
    ...
        BeginPuttingFiles(Notify,Dialog, True);

...
5. ivnik 527 28.09.22 12:30 Сейчас в теме
Оставьте свое сообщение

См. также

Загрузка данных из Excel (из табличного документа) в часто используемые объекты: в справочники, документы, их табличные части, в планы видов расчетов, регистры расчета, регистры сведений Промо

Обработка документов Загрузка и выгрузка в Excel Обработка справочников Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Это перепиленная вдоль и поперек версия всем известной обработки "Загрузка из табличного документа" с диска ИТС. Добавлена возможность грузить в документы, виды расчетов, регистры расчета.

9 стартмани

25.06.2014    16744    33    Дмитрий74Чел    9    

5 способов загрузки из Excel в 1С

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Конфигурация, состоящая из внешнего источника данных и одной обработки. Обработка содержит 5 примеров, как можно загрузить данные в 1С из Excel.

1 стартмани

29.03.2021    54901    56    elephant_x    22    

Парсинг Excel-файла

Загрузка и выгрузка в Excel Универсальные функции Платформа 1С v8.3 1С:Розница 1С:Управление нашей фирмой 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Шаблон внешней обработки для парсинга Excel без использования COM-объектов, с учетом клиент-серверного взаимодействия, на толстом, тонком и веб-клиенте. С учетом требований безопасности и отображением длительных операций.

1 стартмани

15.09.2020    13271    37    LamerSoft    0    

Прыг-Скок...или из MS EXCEL в 1С (8.2) (открытый код) Промо

Обработка документов Обработка справочников Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Универсальная загрузка данных из Microsoft Office Excel. Автоматическая загрузка из любых по форме документов с очень удобным редактором. Почти готовый шаблон для любой конфигурации. Не требует регистрации-бесплатно.

1 стартмани

16.09.2015    79557    372    Tatitutu    50    

Заготовка обработки (внешняя печатная форма) заполнения Excel документа из 1С

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Умеет заполнять как отдельные ячейки, так и таблицы в рамках листов Excel. Удобно при разработке различных “дашбордов” (с графиками, диаграммами), отчетов финансистов (где много формул), заполнения форм документов организации. Эксель шаблон может сделать пользователь (с нужным ему оформлением, формулами и т.д.) и впоследствии самостоятельно этот шаблон менять. Программисту нужно только настроить выдачу данных для заполнения шаблона. Может подключаться как внешняя печатная форма (для обычных и управляемых форм).

2 стартмани

29.07.2020    10045    28    wonderboy    0    

Простой способ загрузить файл Excel на тонком клиенте.

Загрузка и выгрузка в Excel Универсальные функции Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Самый простой способ загрузить файл Excel на тонком клиенте - это скопировать лист Excel в "табличный документ" на форме обработки и обрабатывать уже поля "табличного документа".

1 стартмани

30.10.2019    15060    5    John_d    16    

Загрузка из Excel (без использования com-объектов, без установленного Excel)

Обработка документов Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка не использует com-объект для чтения из файла, не нужен установленный Excel.

1 стартмани

22.03.2019    33001    309    Смешной 1С    29    

Выгрузка и загрузка данных из файла Excel с поиском по любым полям (есть поиск по ссылке, всего три итерации поиска. Управляемые формы или "Такси") Промо

Загрузка и выгрузка в Excel Обработка документов Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Обработка позволяет загружать данные с поиском по ссылке как для загружаемого объекта, так и его свойств. Загружает справочники, документы, планы видов характеристик. Будет полезна как замена использования конвертации данных для задач переноса, а также как классическая загрузка из табличного документа (Excel). Поиск объекта при загрузке выполняется до трех раз с разными полями поиска (поля поиска настраиваются). Также реализована выгрузка в Excel по ссылкам. У обработки удобный интерфейс, в котором разберется даже начинающий пользователь. Загрузка накладных из файлов xls реализована с интеллектуальным поиском колонок с данными. В интеллектуальном поиске поддерживаются все основные типовые печатные формы.

5 стартмани

16.10.2015    73570    536    primat    35    

Конфигурация "Обмен данными Excel"

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Что будет, если скрестить Конвертацию 2.0, Модуль загрузки преобразования в значения БД от конвертации 3.0 и Excel шаблоны? Правильно, получится отличная подсистема "Обмен данными Excel", которую можно встраивать в существующие конфигурации и получить универсальный механизм по загрузке данных из Excel и вводу начальных данных. Данная подсистема позволит заменить множество различных обработок по загрузкам из Excel. Хочу отметить, что все интеграции через веб сервисы 1С по загрузкам soap пакетов (документов xml) можно адаптировать и универсально загружать через данную подсистему, правда, это потребует двух доработок конфигурации, но это возможно, архитектурное решение и идея включены в подсистему "Обмен данными Excel" и хочу Вам сообщить, что уже реализованы и доступны в новом обновлении 1.1.1.1.

2 стартмани

05.03.2019    14638    31    Алексей777    20    

Шаблон загрузки из Excel штатными средствами платформы 8.3 (без com, ado, Excel Application) (обычные и управляемые формы)

Загрузка и выгрузка в Excel Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Россия Абонемент ($m)

Шаблон для быстрой загрузки из Excel (форматы *.xls, *.xlsx) средствами платформы 8.3 с помощью табличного документа. Не нужно работать с MSExcel.Application, ADO. В платформе 8.3 у табличного документа развили метод Прочитать(), и сейчас можно загружать данные не только из файлов *.mxl, но и *.xls и *.xlsx. Подробнее в описании.

1 стартмани

07.12.2018    23573    107    DarkPinch222    4    

Универсальное средство чтения файлов Excel Промо

Универсальные обработки Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Унифицируем чтение файлов Excel, читаем "неудобные" файлы, переносим содержимое таблиц Excel через буфер обмена.

5 стартмани

27.03.2013    37825    170    Infector    4    

Инструменты бухгалтера: Загрузка из Excel

Загрузка и выгрузка в Excel Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Абонемент ($m)

Почему в решениях 1С нет простой и удобной загрузки данных из Excel в документ? Функционал более чем востребован. Есть обработка "Загрузка данных из табличного документа", очень функциональная, но простой и удобной ее не назовешь. Предлагаю простой инструмент для загрузки данных из Excel в любой документ. Обработка реализована в виде внешней обработки заполнения объект и интегрируется в форму документа, данные загружаются в два клика из самого документа. Так же удобство обеспечивается простой и гибкой настройкой сопоставления колонок и реквизитов, для каждого реквизита табличной части настраивается из какой колонки брать значение и как его загружать, загружать как есть или это например, код номенклатуры и по нему нужно искать в справочнике.

1 стартмани

21.11.2018    8834    110    Bazil    20    

Загрузка номенклатуры (с реквизитами, свойствами, несколькими единицами измерений и их коэффициентами, объемами, весами и штрихкодами), прайсов, счетов, накладных, УПД и прочих товарных документов из Excel для Управление торговлей 10.3

Загрузка и выгрузка в Excel Оптовая торговля Ценообразование, анализ цен Прайсы Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 10 Управленческий учет Абонемент ($m)

Загружает номенклатуру, единицы измерения (вес и объем), штрихкоды (поддерживается одновременная загрузка нескольких единиц и штрихкодов), реквизиты и свойства номенклатуры, номера ГТД и серии. Загрузка производится во все документы в которых поддерживается механизм подбора номенклатуры (Заказ покупателя, Поступление товаров и услуг, Установка цен номенклатуры и многие другие). Ищет номенклатуру по наименованию, артикулу, штрихкоду и аналогичным полям в номенклатуре контрагентов. Работает в УТ 10.3 (весьма вероятно будет работать в КА 1 и УПП). Для работы необходима платформа не ниже 8.3.6. Наличие установленного Excel на компьютере не обязательно. Не загружает изображения! Не работает в БП, УТ 11, Рознице 2, УНФ и прочих новых конфигурациях!

3 стартмани

07.10.2018    17722    67    1c.pro.fun    21    

Загрузка УПД в Бухгалтерию 3.0.111.16 из Excel Промо

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Абонемент ($m)

Загрузка УПД из Excel в Бухгалтерию предприятия 3.0.111.16, с заведением номенклатуры в справочник , добавлением ГТД, стран происхождения.

1 стартмани

20.10.2015    34502    35    teyana    28    

Выгрузка отчета в Excel с формулами, используя заполнение - шаблон макета для сложных формул

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Каждому программисту 1с, хоть раз, да приходилось писать выгрузку отчета из 1С в Excel с формулами. Есть много вариантов как это сделать. Но мне захотелось это сделать "по нормальному", используя как можно меньше кода выгрузки в excel, и так чтобы проще было дорабатывать. Идея была проста, все формулы засунуть в макет, и при выводе в Excel просто "проинициализировать" их. Но меня ждал облом, который мне пришлось героически преодолевать. Спойлер - в итоге все получилось...)

1 стартмани

18.07.2018    18820    51    _root    17    

Вы больше не будете разбирать Excel как раньше

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Кому не приходилось разбирать файлы в формате Excel? Все матерятся, плюются, требуют обещаний что "это в последний раз", но таки пишут загрузку из Excel. Потом форматы меняются, строки съезжают, колонки переставляют... Вам это не надоело?

1 стартмани

07.05.2018    39098    64    m-rv    34    

Загрузка данных из Excel Промо

Загрузка и выгрузка в Excel Обработка документов Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Загружает информацию из файлов Excel в любой документ, в шапку документа и в любую табличную часть. Сняты ограничения по количеству загружаемой информации... Теперь есть возможность сохранить настройки формы.

1 стартмани

02.04.2012    56417    1041    TSer1    80    

Приемы эффективной загрузки данных из Excel в 1С

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Показаны приемы эффективной работы с Excel для загрузки данных в 1С.

1 стартмани

13.12.2017    96605    166    alexey.kutya    103    

Загрузка данных из табличного документа (управляемое приложение)

Универсальные обработки Загрузка и выгрузка в Excel Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Загрузка данных из табличного документа для управляемого приложения. По функционалу схожа с типовой обработкой ИТС для обычного приложения.

1 стартмани

10.10.2017    19892    256    karpal    20    

Загрузка из Excel-файла данных в документ Поступление товаров и услуг

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Розничная торговля Склад и ТМЦ Платформа 1С v8.3 1С:Розница 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Загрузка из произвольного Excel-файла документов Поступление товаров и услуг с возможностью создания номенклатуры, обработка позволяет автоматизировать процесс оформления новых поступлений товара.

1 стартмани

04.03.2017    46242    515    gzharkoj    138    

Выгрузка в XML и загрузка из XML. Пример с передачей файла с клиента на сервер и обратно

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Столкнулся с проблемой передачи файла с клиента на сервер и обратно для выгрузки и загрузки данных в XML. Много примеров для выгрузки/загрузки, но не встретил ни одного, где описывался бы механизм передачи файла на сервер и обратно

1 стартмани

03.02.2017    76075    98    Anchoret    6    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP)

Загрузка и выгрузка в Excel Внешние источники данных Платформа 1С v8.3 1С:ERP Управление предприятием 2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    60267    8    milkers    2    

Групповая обработка номенклатуры "Крутотенюшка": выгрузка из 1С в Excel, правка и обратная загрузка в 1С с учетом изменений

Загрузка и выгрузка в Excel Платформа 1С v8.3 1С:Управление торговлей 10 Абонемент ($m)

Эта обработка очень поможет при свертках, переносах, и т.д., когда нужно провести ревизию имеющейся номенклатуры, убрать лишнее, отредактировать, изменить реквизиты, добавить свойства и загрузить все с учетом выполненных изменений в 1С.

1 стартмани

11.04.2016    29949    69    O-Planet    41    

Полезные приемы при работе с Excel из 1С (Версия 3.1)

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Программисту 1С часто приходится работать с таблицами Excel из 1С. Я постарался собрать небольшой FAQ и набор функций для работы с файлами Excel. Надеюсь, кому-то будет полезна данная статья.

1 стартмани

22.09.2015    295852    567    Zerocl    90    

Программная работа с Excel из 1Сv8 - кнопки, макросы, области, отображение листов и полос прокрутки при открытии

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Буду краток, представленная информация здесь это пример работы с Excel программно из 1С, от начала - создание COMОбъект("Excel.Application"), до конца его закрытия. Тут представлен пример, как создать кнопку, присвоить ей макрос, затем добавить лист, прописать в ячейки необходимую информацию, затем установка нужного листа в момент при открытии Excel, корректное отображение листов и полосы прокрутки, затем сохранение файла в необходимый формат. Данная статья не уникальна, само собой, но в данном контексте она консолидирует информацию от различных источников и призвана только помочь в познании методов программной работы с Excel как полноценный законченный пример. Предполагается, что читатель уже имеет опыт в создании СКД отчетов.

1 стартмани

29.07.2015    21218    34    sergik_nsk    5    

Обмен прайс-листами и анализ ценовой политики конкурентов, партнёров и поставщиков в программе 1С:Предприятие

Прайсы Обработка документов Загрузка и выгрузка в Excel Ценообразование, анализ цен Платформа 1С v8.3 1С:Управление торговлей 10 1С:Управление производственным предприятием Управленческий учет Абонемент ($m)

Универсальная программа для загрузки Прайс-листов в базу 1С:Предприятия 8. Основные достоинства: простота использования и широкие функциональные возможности поиска товаров для записи цен. Область применения: обмен прайс-листами и анализ ценовой политики конкурентов, партнёров и поставщиков в программе 1С:Предприятие.

10 стартмани

16.07.2015    41943    4    Destroy    2    

Просмотр файлов разных форматов (PDF, DOC, XLS, MXL, видео, картинок и др.) в управляемой форме 1С

Работа с интерфейсом Универсальные обработки Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Просмотр файлов разных форматов (PDF, DOC, XLS, MXL, видео, картинок и др.) в управляемой форме 1С. Не надо веб-сервера, ActiveX и т.д.

8 стартмани

23.06.2015    53744    127    sss123    32    

И снова "Как сжать картинки для экспорта в EXCEL?" или Умная картинка 8.2

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Прошла уже эпоха , когда экономили на трафике интернета. Но все же...повторюсь. Я предлагаю совершенно новый способ сжатия картинки - эффект в 20 раз !!!

1 стартмани

17.06.2015    39275    72    Tatitutu    14    

Загрузка товаров из таблицы в реализацию и поступление УТ 10.3 по артикулу и производителю + создание товаров и ГТД

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Склад и ТМЦ Платформа 1С v8.3 1С:Управление торговлей 10 Россия Управленческий учет Абонемент ($m)

Обработка встраивается в конфигурацию (только кнопка для вызова обработки) и позволяет быстро и просто загрузить список товаров в реализацию или поступление. В процессе загрузки создаются отсутствующие товары и ГТД.

2 стартмани

03.03.2015    22741    4    taurus__    0    

Работа с Excel. Объединение, Стыковка, Свертка

Универсальные обработки Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка позволяет работать как с одним, так и с несколькими файлами Excel: Объединять файлы со сходной структурой в одну таблицу, Стыковать файлы с разной структурой по ключевому полю, Группировать результат по выбранным полям и суммировать числовые поля.

1 стартмани

19.02.2015    32530    44    Ekovichev    7    

Нестандартная загрузка из Excel

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Взгляд на привычную задачу под неожиданным углом - пусть пользователь прямо в Excel решает, что ему надо, и грузит в 1С только нужное. Установите любой отбор, выделите фрагмент, и вот он уже в 1С. Для обычных и УФ 8.3

1 стартмани

12.11.2014    38703    281    Yashazz    47    

Загрузка данных из табличного документа (УФ)

Обработка документов Обработка справочников Загрузка и выгрузка в Excel Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Загрузка данных из табличного документа (УФ) с сохранением/восстановлением настроек, загрузкой в план счетов, загрузкой реквизитов объектов типа ПВХ

2 стартмани

22.05.2014    32415    260    blindcat2006    15    

Универсальная загрузка табличных данных из файла Microsoft Excel

Загрузка и выгрузка в Excel Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Мастер загрузки произвольных табличных данных из книг Microsoft Excel в объекты информационной базы 1С: Предприятие (управляемое приложение).

1 стартмани

30.04.2014    34854    443    McSeem    21